Snowmobile Fanatics banner
1 - 3 of 3 Posts

· Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
I'm trying to get my 1994 Storm motor underway and I have it mounted in a 1987 Indy 600 chassis. I picked up a so-called 1994 Storm CDI box off of ebay, which the seller informed me that it came off of a running 94 Storm with the part number 3084662. Problem is, according to parts guides, Polaris replaced this CDI box with the item number 3085070. Does anyone know if there is a difference between these two part numbers?

Pictures attached is of the connectors for the CDI box and the connectors coming from the magneto:


Wires coming from the magneto


Wires coming from the CDI box

The CDI box is missing the green wire. Can anyone link this to the actual sled this came off of? Thanks! -Steve
 

· Registered
Joined
·
2,738 Posts
3084662 was used only on 1994 storms.
3085070 was used only on 1995 storms.
According to the crappy pictures of the microfiche, both CDI's have two plugs with three connections each. However, I wouldn't rely too heavily on that. On the other hand, 3085070 substituted 3084662, which means the two parts should be interchangeable. Obviously this isn't the case since the CDI doesn't fit.
 

· Registered
Joined
·
36 Posts
Discussion Starter · #3 ·
That helps, didn't know the two part numbers were for different years. Yeah, I figured it was a no brainer that this cdi wouldn't work after receiving it, just didn't know if someone else ran into this and somehow rewired the setup to work, maybe like the green wire was just some kind of accessory line. Guess I gotta hunt a new CDI :)
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top