Snowmobile Fanatics banner

1 - 8 of 8 Posts

·
Registered
Joined
·
741 Posts
Discussion Starter · #1 ·
I usually dont like posting questions but I have a couple I cant figure out. I got a 98 indy switched over to a gen. 11 chassis, and i was wondering where i could get the blue/black/red or whatever headlight covers? i checked ebay but didn't find anything. also this thing makes some weird noises... like a banging noise from (what seems like) the stock can, but i have a hard time telling exactly where its coming from. any ideas? it also backfires a bit, not a gunshot loud but a popping noise when i get on the gas and let off, and it is running rich. Is there any way i can adjust the carbs to lean it out a bit? I searched but couldn't find what I was looking for. Thanks guys
 

·
Registered
Joined
·
66 Posts
is the can plugged up i had a mouse nest in my exhaust and air box one year it ran like hell till i cleaned the air box out and blew the shit out of the exhaust.
 

·
Registered
Joined
·
741 Posts
Discussion Starter · #3 ·
haha im thinking you may be right, i found a mouse nest under my airbox and some acorns in the bottom of the sled. ill have to check. But when i was looking at buying the sled i didn't hear anything..
 

·
Registered
Joined
·
741 Posts
Discussion Starter · #4 ·
didn't find any nest, the can just rattles around...? like there is something metal loose in it. but i guess i now have a reason to get a MBRP can haha. still looking to find out where i can find those headlight covers...
 

·
Registered
Joined
·
1,109 Posts
The low end pops and gurgles are very common with this particular motor. Most will suggest power packs and a boost bottle to clean up the bottom end issues. It does work reasonably well. Not 100% perfect but much better. I've left mine stock jetting and the bottle and PP made a difference. I don't know I'd would start with jetting issues yet as we are no where the temps to ride now. Try the Boost Bottle and go from there.

As for the rattle, who know. Very hard to tell without hearing it for ones self. Loose baffles in the can, chaincase problems, etc could be the problem.
 

·
Registered
Joined
·
659 Posts
Is the sled your talking about the one in your picture cause that is a wedge chassis not a gen. 2. if its not the same sled as the one your talking about sorry I posted lol.
 

·
Registered
Joined
·
741 Posts
Discussion Starter · #7 ·
Thanks dman, ill check into the boost bottle. and xlt_demon, thats my old 91 indy, which is dead now :/. Ill have to update it in a bit
 

·
Registered
Joined
·
659 Posts
Vamped400 said:
Thanks dman, ill check into the boost bottle. and xlt_demon, [highlight=yellow]thats my old 91[/highlight=yellow] indy, which is dead now :/. Ill have to update it in a bit
Ahh I see.
 
1 - 8 of 8 Posts
Top