Snowmobile Fanatics banner

1 - 13 of 13 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter #1
i have a 1994 xlt rmk, and last season i smoked two belts and had 2 ride back on a bad belt, about 20 miles, and after that when i replaced the belt, i heard this thumping sound and it would slip, so i took it in and found out i had a crack in my clutch, they said it was from the slipping bel cause heat and cracked it, so 400 bux later they got me a new clutch and weights and put it in, now i have taken it out once since then, and now the clutch doesnt engage till really high, i dont like it, becase now on the trail im running reall high rpms, what is tis? what can i do?
 

·
Registered
Joined
·
85 Posts
sounds to me like they have put a heavier spring and weights in, you should have them set it back to stock if your sled isn't piped and your not a real aggressive rider on the trails.
 

·
Registered
Joined
·
62 Posts
Discussion Starter #4
well i mean its not that i dont like it but im not used to it so its weird i just wanted 2 make sure thats not gonna hurt anything, and i dont ride much "trails" anyway i havnt really had a chance to get out and really ride it will it affect my riding style cuz i mainly ride mountains, a lil climbin and powder so is it gonna effect that and no my sled isnt piped, well its got an older (2000) single slp pipe
 

·
Registered
Joined
·
62 Posts
Discussion Starter #6
well its been ahwile if i remember right it used to engage at 4000 now it engages at around 6500 but 7000 when cold
 

·
Registered
Joined
·
85 Posts
thats waaaaaay to high of an engagement !!!
check to see that there isn't any old belt fragments in the clutches, a warn belt?
a broken spring? thats just not right.
good luck, dave
 

·
Registered
Joined
·
57 Posts
Holy crap , The only time i have ever seen engagement like that is on a prostocker , you need to make sure that you've got the right spring and weights in the clutch
 

·
Registered
Joined
·
324 Posts
Sounds like it engages in the power band. How are your wrists? Sounds like you have 30-33 gram weights in it. If the spring is purple try going down to a white or red.
 

·
Registered
Joined
·
62 Posts
Discussion Starter #11
ok well i havnt had a chance to look at what color spring i sin it, but will engagement like this hurt it? it seems like i have less top end speed because my rpms build too quickly it seems like when i used to hit 80 at 8-9 grand now im hittin about 60 at that easily, but will it hurt and will i still have the same top end maybe im wrong about the speed to rpms thing but will it affect my op speed?
 

·
Registered
Joined
·
324 Posts
The out of the hole might be good but I would be more worried about your rpm peak. The higher the rpm you urn the more wear on the motor. If you are running 10 or 11 grand at 70 or 80 you are in for some serious rebuild time. You will also go through belts unless you buy a high qulity one. I know it is nice to have the higher engagement but it is not recomended to go over 6000 unless you are into sno cross or pro stock. Most sleds 5000 would give you the same effect and be alot easier on the motor.
 
1 - 13 of 13 Posts
Top