Snowmobile Fanatics banner

1 - 10 of 10 Posts

·
Registered
Joined
·
563 Posts
Discussion Starter · #1 ·
Ok here is the story. the sled belongs to a friend. A few weeks ago we went riding and it idled and ran good. On the way home the base gasket blew out on the clutch side "recent rebuild and nuts came loose". We pulled the jugs and replaced the gasket. No more leaks. At the same time he wanted to put on my set of triple pipes I had from my old XLT. Put them on started it up and it would not idle. It will somewhat idle for a few seconds and then drop down and die. We pulled all the carbs and cleaned the jets and blew out the carbs. Put them on and adjusted them in sync. Still the same. Checked compression and they all are 125psi. New plugs. The kicker is that it was running fine before the gasket blew. I have owned and worked on sleds for years but this one has me at a loss. Oh we even checked to see if it was leaking fuel through the vacuum hose to the fuel pump. Does anybody have any other ideas? It just acts like it's flooding.
 

·
Registered
Joined
·
526 Posts
Take some starting fluid and make sure you don't have a crank seal that is leaking, or cab boot that is bad.. if idle changed thats your problem...
 

·
Registered
Joined
·
378 Posts
Well I would take a look in to see if you have the right settings for the carbs with the pipes that you have on. If you don't know what the setting were put the stock ones on and see if the sled runs good or not.
 

·
Registered
Joined
·
161 Posts
I had the same problem with my sled and sure enough i did not get the jug on right there for it was sitting funny causing it to suck air by the base gasket. So i just put some permitex and tighten it down good and problem solved. Hope that helps
 

·
Registered
Joined
·
9,987 Posts
It's the pipes, you need to re-jet.

Put the original pipe back on, and it should run normal.
 

·
Registered
Joined
·
258 Posts
In reading your original post you do not mention that you re-jetted the carbs after adding the tripple pipes, did you? If not you need to. Only time you dont need to rejet is if youre adding a can.
 
1 - 10 of 10 Posts
Top