Snowmobile Fanatics banner

1 - 14 of 14 Posts

·
Registered
Joined
·
562 Posts
Discussion Starter #1
I'm getting ready to put my xtra 10 in my 94 XLT and have been doing alot of reading. I am going to move the front hole up and the rear hole forward. It says that you can bolt it in directly but it won't work. My question is why won't it work> Will it not have enough suspension travel or what? I am just wondering. Thanks.....Marc
 

·
Registered
Joined
·
5,686 Posts
If you try to use the stock holes, you won't be able to tighten the track and suspension will be rock hard.
 

·
Registered
Joined
·
1,374 Posts
you will get maybe 3 inches of travel, the suspension will not be able to compress. I was able to use the stock front hole in a 1995 xcr, but had to move the rrear hole ahead, just in back of the heat exchanger, but still in the steel plate, barely. this worked for us.
 

·
Registered
Joined
·
562 Posts
Discussion Starter #4
ok, I have it in, I moved the rear hole forward like you guys say and then I drilled a hole above the existing on the front. Now I have it in the bottom hole in the front and the rear, is this ok or will it mess something up? It doesn't sit very high so I don't think it's going to make it unstable. Why do you all always put them in the upper holes? Just wondering
 

·
Registered
Joined
·
841 Posts
The distance between the front and rear mounting points needs to be a specific distance. Regardless of the sled, it has to be set for a xtra-10. Else the whole suspension's geometry will be off. It will not compress or transfer, basically won't work.

As for moving the mounting points up/down. Again there are several combos which you can experiment with.
Things to be aware of......if you lower the front too much, there is a risk of stabbing the track with the rail.
If you lift the front too high, it will give you too much ski pressure and will be plowing through the snow.
You get the same effect moving the back up/down.
DO NOT put the front in the lowest hole and the back in the highest.........hopefully you get what I'm trying to say.
I used to have a nice factory diagram for this (pictures do wonders), but who knows where it diappeared to.
 

·
Registered
Joined
·
562 Posts
Discussion Starter #6
ok, I was messin around with it and had it in the upper hole in the front and the lower hole in the rear. It looked like the only part of the track that was on the ground was the very back of the track. So then I moved the front to the lower hole and it seemed to level out the track. I was looking at where you said about the track getting caught in the end of the rail and to me it looks like there is plenty of room to clear. When I had the front in the upper hole it seemed like mt studs were very close to the tunnel rails so that is why I moved to the lower holes.
 

·
Registered
Joined
·
187 Posts
I did an x-10 conversion in a 92 xcr 440 sucessfully. Took measurements from a short track sled that came stock with an x-10. Take measurements going off of the driveshaft. Back, up, down, etc. Measure twice, drill once! You have to have the holes correct in order for the suspension to work properly, otherwise the suspension will not cycle properly and you could break something or have track tension problems when cycling. -Polaris Doc
 

·
Registered
Joined
·
2,257 Posts
You should have no more than 4" of sag when you sit in the sled. I prefer 2-3" myself. If it feels springy, the shocks may need a rebuild and/or the torsion springs are weak.
 

·
Registered
Joined
·
562 Posts
Discussion Starter #11
well the shocks are fine but I noticed when I pick up the back of the sled to take the sag out of it then push back down it will go down some before the rear shock starts to compress. I watched it and the lower shock mount will move down and forward some before it stops. After it has stopped the rear shock will start to compress like it should and then it will start to get more stiff. If i pull the back up to take all the slack out of the suspension it's like the rear shock has to move forward when i first start to push it down then after the suspension is down so far then the rear shock will start to compress. Do i not have the rear mounting holes far enough forward?
Originally posted by Ultra680
[br]You should have no more than 4" of sag when you sit in the sled. I prefer 2-3" myself. If it feels springy, the shocks may need a rebuild and/or the torsion springs are weak.
 
1 - 14 of 14 Posts
Top