Snowmobile Fanatics banner
1 - 12 of 12 Posts

·
Premium Member
Joined
·
15,520 Posts
Discussion Starter · #1 ·
My zrt will cruise along and run ok as long as i do not hammer down on the gas, If I do it sounds like it is running out of fuel or something it just wont' do it, sounds funny. If I go semi slow up to 80 it is fine, past 80 it won't go. What do you all think I should go through? Water in Gas? Fuel pump? And yes it has new plugs. THANKS!
 

·
Registered
Joined
·
3,188 Posts
Have you cleaned the carbs lately?

I would check the fuel lines for any restrictions as well as the fuel filter. There should be at least 2 fuel filters. One in-line and one in the tank to filter out the big stuff. It could be alot of things, but i'd start with the simple stuff.
 

·
Registered
Joined
·
70 Posts
I had a similar problem when it was 20 below. I went to hammer it across the lake and I couldn't get over 65. Come to find out there was ice in my gas line. I actually so chunks of ice stuck before the filter. As the day warmed the problem went away. Sounds like a fuel problem either bad gas or unclean carbs or fuel line.
 

·
Registered
Joined
·
50 Posts
If it is a problem with water in your gas just add about 1/2 bottle of Iso-HEET Fuel system dryer and antifreeze (Isopropyl Alcohol) to your tank. This is made by the makers of STA-BIL and will remove any water from your fuel. If you ride in very cold weather or deep powder this will save you a lot of head aches. A long time ago some one told me to not use (Methanol Alcohol) type fuel dryers but I can't rember the reason why. Maybe someone here can inform us on this. I add about 1/4 bottle at every fillup, more if I know conditions will be severe.
 

·
Registered
Joined
·
2,573 Posts
definately chk the filter as stated, and jets. Maybe simply running carb cleaner for 2-strokes would do in this case.
 

·
Premium Member
Joined
·
15,520 Posts
Discussion Starter · #7 ·
i have never used carb cleaner. I will put dry gas in her this weekend when I ride her again. It is 2 hrs away right now. I don't want to touch the carbs because it has the UFO's in the carbs and everyone me not to touch them bacause they are extremely touchy. I am wondering about that filter in the tank.
 

·
Registered
Joined
·
1,075 Posts
I would say it is in your carbs.you should have them checked out by someone who knows what there doing. a little money spent now will probably save you a lot later.
 

·
Premium Member
Joined
·
15,520 Posts
Discussion Starter · #9 ·
just tried dry gas, went around for 20 mins, still bad. But I think that It may be a little better. I took one of the carbs off to drain the float bowls, the freakin' screws won't come out, them baby's are in there! Now, I don't know what I am going to do. If the break, it is off to the machine shop at work with them and I really don't want to do that.
 

·
Registered
Joined
·
133 Posts
First off, has it ever run right with the UFO's most don't. Also if you have to ease into the throttle sounds like you starving for fuel or carb sync is possibly out of whack. What do the plugs look like? One thing with the zrt 600 engine is it is hard to burn it down, will loose power and let you know that something is wrong before it sticks. If I were a betting man i would say your plugs are white, if so yank the ufo's and go back to stock. If plugs look good start looking at the clutching. If it gets worse the colder it is its definatley a lean condition.
 

·
Registered
Joined
·
614 Posts
Check the pulse line that makes the full pump work. It may be kinked or have a leak. Its the fatter black line that goes from the crank case to the fuel pump. Just a thought, happened to my zrt, I had a little crack right at the crank case.
 

·
Premium Member
Joined
·
15,520 Posts
Discussion Starter · #12 ·
I will check that when it is light out sleddaver. Indytriple-- It has ran fine for years with the UFO's. Plugs are golden brown like a chicken mcnugget. :))) I Put about a cup of dry gas (Iso prop) in her with 3/4 tank and it seems to be doing better. I didn't really open it up but it hardly did it from a stop anymore. Maybe that is all that my problem was. I couldn't get the float bowls off when I tried. The screws won't come out. Anybody know any tricks to solve this little problem??? THANKS! I Love this forum!!!
matt
 
1 - 12 of 12 Posts
Top